Basic Router Configuration2


Router Interface Configuration
You will now configure the individual router interfaces with IP addresses and other information. First, enter the interface configuration mode by specifying the interface type and number. Next, configure the IP address and subnet mask:
R1(config)#interface Serial0/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0
It is good practice to configure a description on each interface to help document the network information. The description text is limited to 240 characters. On production networks a description can be helpful in troubleshooting by providing information about the type of network that the interface is connected to and if there are any other routers on that network. If the interface connects to an ISP or service carrier, it is helpful to enter the third party connection and contact information; for example:
Router(config-if)#description Ciruit#VBN32696-123 (help desk:1-800-555
-1234)
In lab environments, enter a simple description that will help in troubleshooting situations; for example:
R1(config-if)#description Link to R2
After configuring the IP address and description, the interface must be activated with the no shutdown command. This is similar to powering on the interface. The interface must also be connected to another device (a hub, a switch, another router, etc.) for the Physical layer to be active.
Router(config-if)#no shutdown
R1(config-if)#clock rate 64000
Repeat the interface configuration commands on all other interfaces that need to be configured. In our topology example, the FastEthernet interface needs to be configured.
R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#description R1 LAN
R1(config-if)#no shutdown

Each Interface Belongs to a Different Network:
this point, note that each interface must belong to a different network. Although the IOS allows you to configure an IP address from the same network on two different interfaces, the router will not activate the second interface.
R1(config)#interface FastEthernet0/1
R1(config-if)#ip address 192.168.1.2 255.255.255.0
192.168.1.0 overlaps with FastEthernet0/0
R1#show ip interface brief

FastEthernet0/1 192.168.1.2 YES manual administratively down down

3 comments:

Anonymous said...

Free Submit blogger and website site URL in directory make search engine friendly. Increase visibility, Increase traffic to blogspot and website
http://freeurlsubmitdirectory.blogspot.com/

Muhammad sameer on October 11, 2008 at 12:04 PM said...

nice dude
if any one want to know about stock market stock tips stock news and more check the below site

http://ww.khi-stock.blogspot.com

Anonymous said...

i want many thins about routers configuration.

Post a Comment

 

NBA Live Streaming. Copyright 2008 All Rights Reserved Revolution Two Church theme by Brian Gardner Converted into Blogger Template by Bloganol dot com | Distributed by Blogger Templates Blog